AOSP

GravityBox Introduction

First and foremost, you must have a vanilla  AOSP ROM (or close to)  installed on your device. GravityBox comes in two flavors: Android 4.1, 4.2 or 4.3 (Jelly Bean) and Android 4.4+(Kit Kat). Plain AOSP ROM’s can be found installed stock on Google Nexus & Google Play Edition devices. Recently support has also been added to the Moto G Dual SIM (stock Kit Kat only). If you have an MTK device with Jelly Bean, you’re in luck. It supports a majority of MTK6589, MTK6577, MTK8389 devices. For Kit Kat, initial MTK support has just been added for the ThL 5000 (MTK6592).

But wait! My device / ROM was not mentioned! My ROM is based on AOSP, will that work?

stop

Installing on a proprietary stock manufacturer ROM like Samsung or HTC, or any custom ROM like Cyanogenmod or Paranoid Android is like installing two ROM’s on top of each other. Impossible and preposterous. Even though your ROM may look like stock AOSP, the code behind the scenes has been modified heavily.

If you insist and install it anyway, you’re on your own. No support is offered. You are not welcome to report “bugs” on neither the XDA thread, Google Plus nor any other method of contacting the developer. You’re free to create your own thread somewhere else to talk about using GravityBox on unsupported devices / ROM’s. If your favorite custom ROM is missing features you require, please contact your ROM team for further customization options.

Before we begin, please read the entire first post of the appropriate XDA Developers forum thread. For Jelly Bean, see here and for Kit Kat see here. Please especially note the compatibility information in red. We also have our own FAQ page.

Now that you’ve verified you qualify to enhance your device with GravityBox to the fullest, we’ll proceed to installation.

Advertisements